ノートPCのLenovo G565のWindows10がうまく動かなくなったので、修復した

ノートPCのLenovo G565のWindows10がうまく動かなくなったので、修復した。

ノートPCのLenovo G565のCPUを換装したものを去年Windows10にOSを入れ直したあと、あまり使って無くて放置してたのだけど、久しぶりに使おうとしたらWindows10の調子が悪いことに気がついた。

Windows10のOSは起動してサインインまでは普通に動いているみたいなのだけど、アプリの起動がおかしい。
ブラウザのEdgeとかMS公式ストアが起動できない。IEは起動できる。
ストアアプリ(UWP?)が全部動かないみたいで、電卓さえ起動しない。スタートメニューでクリックしても反応がないし、コマンド名でcalc.exeを起動しようとしても駄目だ。

Windows Updateを掛けてみようと思ったら、それも開くことができない。
Windows7風のコントロールパネルは開くことができるのだけど、Windows8.1風の「設定」の画面が開かない。
ということで困った状態になっている。

CPUを換装したあとWindows7では問題なく使えていたのだけど、Windows10だとまずいのだろうか?
古いIntelのCPUがWindows10のサポート対象外になるというのがあったけど、AMDのTruionⅡとかも同じような問題で引っかかったとか?
そもそもWindows10へのアップグレードの対象外の機種だから仕方ないといえば仕方ないのだけど。Windows7に戻すのは避けたいなあ。もし直らなかったら、いっそUbuntuをインストールするかなとか考えてた。

とりあえず、OSを初期状態に戻す「PCのリセット」をしてみようと思ったが、やり方を忘れてしまっていた。
Windows10では、OSを初期状態に戻すためのリカバリーみたいな機能で「PCのリセット」というのがある。
PCのリセットって紛らわしいから、あまりこの機能をこの言葉で呼ばないみたいだなあ。ネットでやり方を検索してもあまり出てこない。

普通はPCの「設定」メニューから辿ってリセットに辿り着くのだけど、いまはうまく動かなくて「設定」を開くことができない。
リセットという名前で検索して、その機能を起動しようとしてもうまくいかない。

仕方ないので電源立ち上げ中に強制電源オフを数回繰り返して、復元モードに入ってPCのリセット(リカバリ)を開始した。
数時間かけてリセットが終了し、Windows10のインストール直後と同じ状態になった。

Windows10の初期設定をして、無事にまっさらな状態のWindows10に戻った。
うまく動かなかったストアアプリ(UWP)やブラウザのEdgeや電卓や「設定」も無事に動くようになった。
動作もきびきびした状態だ。
デバイスマネージャーでも特にドライバが入らなかったものも無く、良い感じだ。

Windows10が壊れた原因がわからない。
Windows10にしてからどのタイミングでOSが壊れてたのだろうか?、謎だ。
あまり使っていなかったが、Visual Studioとか色々入れては消してというのをやったくらいかなあ。
あと、Windows Updateとかも多少はやっていたと思う。

試しにまっさらになったWindows10だが、更新は最初にダウンロードされて入っている。
さらにWindows Updateを掛けてみたが、特に問題は起きていない。

あとは、Lenovoのドライバの問題だろうか?
最初にWindows10にしたときには、いくつかドライバが自動で入らなかったデバイスがあったような気がする。なので、Windows8/8.1用のドライバをダウンロードして入れたような気がするのだが、ちゃんと覚えていない。
HDDにそのあたりのファイルが取ってあったはずだったのだが、PCリセットで消えてしまった。
そのフォルダだけは、ちゃんとバックアップをして保存しておけばよかったのに、ちょっと失敗だったなあ。

結局、結論としては、原因は不明だがPCリセットすれば修復することができたということになる。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

Time limit is exhausted. Please reload CAPTCHA.

× 9 = 90